Verifying that all aspects of service is functional. Symptoms: We are carrying out network infrastructure upgrade work at the Queen Street Datacentre. Customers who connect at this location may experience upto 2 x 30 minutes of downtime while we carry out this work. We apologize for any inconvenience this may cause and appreciate your understanding as we improve our infrastructure.
Posted Jul 21, 2026 - 03:24 NZST
Update
Maintenance in progress. Symptoms: We are carrying out network infrastructure upgrade work at the Queen Street Datacentre. Customers who connect at this location may experience upto 2 x 30 minutes of downtime while we carry out this work. We apologize for any inconvenience this may cause and appreciate your understanding as we improve our infrastructure.
Posted Jul 20, 2026 - 22:21 NZST
In progress
Maintenance in progress. Symptoms: We are carrying out network infrastructure upgrade work at the Queen Street Datacentre. Customers who connects at this location may experience 2 x 30 minutes of downtime while we carry out this work. We apologize for any inconvenience this may cause and appreciate your understanding as we improve our infrastructure.