Delayed email delivery to Outlook/Hotmail

Incident Report for Voyager

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 14:46 NZDT

Update

Service appears to be fully restored. We’ll continue to keep a close eye on things to ensure continued stability. Thank you for your patience!
Posted Feb 27, 2026 - 14:45 NZDT

Update

Microsoft is still working on resolution. We will share an update once we have more information.
Posted Feb 26, 2026 - 15:32 NZDT

Update

We are continuing to wait for updates from Microsoft. Thank you for you patience!
Posted Feb 26, 2026 - 12:47 NZDT

Update

We are still waiting for update from Microsoft.
Posted Feb 26, 2026 - 11:55 NZDT

Update

While we are waiting on this third- party issue to be resolved, we have implemented a work around for many of our customers. We are working on solution for the remaining customers and will advise soon
Posted Feb 26, 2026 - 11:54 NZDT

Update

Symptoms: [Update 11:30] -
We are currently aware of a third‑party issue affecting email delivery to Microsoft‑managed email services.
This appears to be a Microsoft‑side issue affecting many email providers, including ours.
Our engineers are monitoring the situation.
For further updates, please visit the status page at 1stdomains.nz
Posted Feb 26, 2026 - 11:31 NZDT

Investigating

Symptoms: We are currently aware of a third‑party issue affecting email delivery to Microsoft‑managed email services.
This appears to be a Microsoft‑side issue affecting many email providers, including ours.
Our engineers are monitoring the situation.
For further updates, please visit the status page at 1stdomains.nz
Posted Feb 26, 2026 - 09:32 NZDT
This incident affected: Hosting (Domains, Email).